PT-2023-19842
CVE-2023-2496
·
Published
2023-05-23
·
Updated
2023-05-31
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
The Go Pricing - WordPress Responsive Pricing Tables plugin versions up to, and including, 3.3.19
Description
The issue is related to unauthorized arbitrary file uploads due to an improper capability check on the
validate upload function. This allows authenticated attackers with a previously granted role to upload arbitrary files on the affected site's server, potentially making remote code execution possible.Recommendations
For versions up to, and including, 3.3.19, update to a version higher than 3.3.19 to resolve the issue. As a temporary workaround, consider restricting access to the
validate upload function until a patch is available. Additionally, review and limit the roles granted access to the plugin to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾