PT-2023-24132

CVE-2023-33000

·

Published

2023-05-16

·

Updated

2023-05-31

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Jenkins NS-ND Integration Performance Publisher Plugin versions 4.8.0.149 and earlier
Description The issue concerns the Jenkins NS-ND Integration Performance Publisher Plugin, where credentials are not masked on the configuration form, allowing potential attackers to observe and capture them. Although the credentials are stored encrypted on disk, the lack of masking on the job configuration form increases the risk.
Recommendations For versions 4.8.0.149 and earlier, update to version 4.11.0.48 or later, which masks credentials displayed on the configuration form. As a temporary workaround, consider restricting access to the configuration form to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-GQXR-HVRW-6HFH
Found an issue in the description? Have something to add? Feel free to write us 👾