PT-2023-25792
CVE-2023-3713
·
Published
2023-07-18
·
Updated
2023-07-27
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
ProfileGrid plugin for WordPress versions up to, and including, 5.5.1
Description
The issue is related to a missing capability check on the
profile magic check smtp connection function, allowing authenticated attackers with subscriber-level permissions or above to update site options arbitrarily. This can lead to privilege escalation.Recommendations
For ProfileGrid plugin for WordPress versions up to, and including, 5.5.1, update to a version higher than 5.5.1 to resolve the issue.
As a temporary workaround, consider disabling the
profile magic check smtp connection function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾