PT-2023-27040

CVE-2023-39631

·

Published

2023-01-09

·

Updated

2026-10-12

Description by

CVSS 2.0
10
Critical
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions LangChain versions 0.0.245 through 0.0.307
Description The issue is related to incorrect code generation control in the numexpr library of the LangChain framework, allowing a remote attacker to execute arbitrary code via the evaluate function. This can lead to exploitation by a remote attacker.
Recommendations For versions 0.0.245 through 0.0.307, update to version 0.0.308 or later, which includes a patch for the numexpr dependency issue. As a temporary workaround, consider disabling the evaluate function in the numexpr library until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-F73W-4M7G-CH9X
PYSEC-2023-162
PYSEC-2023-163
Found an issue in the description? Have something to add? Feel free to write us 👾