PT-2023-29270

CVE-2023-4455

·

Published

2023-08-21

·

Updated

2023-08-24

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions wallabag versions prior to 2.6.3
Description The issue is related to Cross-Site Request Forgery (CSRF) in the wallabag GitHub repository. This allows attackers to arbitrarily delete API keys via the /developer/client/delete/{id} endpoint.
Recommendations For versions prior to 2.6.3, update to version 2.6.3 or higher, especially if you have more than one user and/or have open registration. As a temporary workaround, consider restricting access to the /developer/client/delete/{id} endpoint until the update is applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-GJVC-55FW-V6VQ
GHSA-GVVX-FC6P-2H9X
Found an issue in the description? Have something to add? Feel free to write us 👾