PT-2023-29707

CVE-2023-45818

·

Published

2023-10-19

·

Updated

2023-10-26

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions TinyMCE versions prior to 5.10.8 TinyMCE versions prior to 6.7.1
Description A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo and redo functionality. When a carefully-crafted HTML snippet passes the XSS sanitisation layer, it is manipulated as a string by internal trimming functions before being stored in the undo stack. If the HTML snippet is restored from the undo stack, the combination of the string manipulation and reparative parsing by either the browser's native DOMParser API (TinyMCE 6) or the SaxParser API (TinyMCE 5) mutates the HTML maliciously, allowing an XSS payload to be executed. This vulnerability also impacts related TinyMCE APIs and plugins, including tinymce.Editor.getContent({ format: 'raw' }), tinymce.Editor.resetContent(), and the Autosave Plugin.
Recommendations
  • Upgrade to TinyMCE 5.10.8 or higher for TinyMCE 5.x.
  • Upgrade to TinyMCE 6.7.1 or higher for TinyMCE 6.x.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-V65R-P3VV-JJFV
Found an issue in the description? Have something to add? Feel free to write us 👾