PT-2023-30725
CVE-2023-4820
·
Published
2023-10-16
·
Updated
2025-03-05
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
PowerPress Podcasting plugin by Blubrry WordPress plugin versions prior to 11.0.12
Description
The issue concerns the PowerPress Podcasting plugin by Blubrry WordPress plugin, where it does not properly sanitize and escape the media URL field in posts. This could allow users with privileges as low as contributor to inject arbitrary web scripts, potentially targeting a site admin or superadmin.
Recommendations
For versions prior to 11.0.12, update to version 11.0.12 or later to resolve the issue. As a temporary workaround, consider restricting the ability of contributors to edit posts or limiting their access to the media URL field until the update is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾