PT-2023-31107

CVE-2023-4919

·

Published

2023-10-19

·

Updated

2023-10-27

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions iframe plugin for WordPress versions up to, and including, 4.6
Description The issue is related to Stored Cross-Site Scripting via the iframe shortcode due to insufficient input sanitization and output escaping. This allows authenticated attackers with contributor-level permission and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For versions up to, and including, 4.6, update to version 4.7 to fully patch the issue. As a temporary workaround, consider restricting access to the iframe shortcode for users with contributor-level permission and above until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾