PT-2023-31601

CVE-2023-5062

·

Published

2023-09-19

·

Updated

2023-09-20

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions WordPress Charts plugin for WordPress versions up to, and including, 0.7.0
Description The issue is related to Stored Cross-Site Scripting via the wp charts shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For WordPress Charts plugin for WordPress versions up to, and including, 0.7.0: Update to a version later than 0.7.0 to resolve the issue. As a temporary workaround, consider restricting access to the wp charts shortcode for users with contributor-level and above permissions until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾