PT-2023-3600
CVE-2023-33285
·
Published
2021-09-15
·
Updated
2025-09-28
Description by
CVSS 3.1
5.3
MediumMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions
Qt versions 5.x before 5.15.14
Qt versions 6.x before 6.2.9
Qt versions 6.3.x through 6.5.x before 6.5.1
Description
The issue is related to a buffer over-read in the QDnsLookup component of the Qt framework, which can be exploited by a remote attacker using a specially crafted reply from a DNS server, potentially leading to a denial of service. The exploitation involves reading beyond the valid boundaries of a data buffer.
Recommendations
For Qt versions 5.x before 5.15.14, update to version 5.15.14 or later.
For Qt versions 6.x before 6.2.9, update to version 6.2.9 or later.
For Qt versions 6.3.x through 6.5.x before 6.5.1, update to version 6.5.1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾