PT-2023-5107
CVE-2023-4738
·
Published
2023-09-02
·
Updated
2025-03-30
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
vim versions prior to 9.0.1848
Description
The issue is a heap-based buffer overflow in the vim text editor, specifically in the
vim regsub both function, caused by a dynamic memory buffer overflow. This can allow an attacker to execute arbitrary code.Recommendations
For versions prior to 9.0.1848, update to version 9.0.1848 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
vim regsub both function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾