PT-2023-5907
CVE-2023-41419
·
Published
2023-08-31
·
Updated
2026-10-09
Description by
CVSS 2.0
10
CriticalMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Gevent versions prior to 23.9.1
Gevent version 23.9.0
Description
The issue in Gevent is related to insufficient validation of executed requests in the WSGIServer component, allowing a remote attacker to escalate privileges via a crafted script. This can impact the integrity, availability, and confidentiality of protected information.
Recommendations
For Gevent versions prior to 23.9.1, update to version 23.9.1 or later to resolve the issue.
For Gevent version 23.9.0, update to version 23.9.1 to resolve the issue.
As a temporary workaround, consider restricting access to the WSGIServer component until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾