PT-2023-6261

CVE-2023-43623

·

Published

2023-10-10

·

Updated

2023-10-16

Description by

CVSS 3.1
5.3
Medium
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions Mendix Forgot Password (Mendix 10 compatible) versions prior to V5.4.0 Mendix Forgot Password (Mendix 7 compatible) versions prior to V3.7.3 Mendix Forgot Password (Mendix 8 compatible) versions prior to V4.1.3 Mendix Forgot Password (Mendix 9 compatible) versions prior to V5.4.0
Description The issue is related to the "Forgot Password" function of the Mendix platform, which is associated with non-persistent runtime. Exploitation of this issue allows a remote attacker to perform a brute force attack. Applications using the affected module are vulnerable to user enumeration due to distinguishable responses, enabling an unauthenticated remote attacker to determine if a user is valid or not.
Recommendations For Mendix Forgot Password (Mendix 10 compatible) versions prior to V5.4.0, update to version V5.4.0 or later. For Mendix Forgot Password (Mendix 7 compatible) versions prior to V3.7.3, update to version V3.7.3 or later. For Mendix Forgot Password (Mendix 8 compatible) versions prior to V4.1.3, update to version V4.1.3 or later. For Mendix Forgot Password (Mendix 9 compatible) versions prior to V5.4.0, update to version V5.4.0 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾