PT-2023-6464
CVE-2023-45129
·
Published
2023-09-26
·
Updated
2024-06-15
Description by
CVSS 4.0
6.9
MediumMetricsAV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
Synapse versions prior to 1.94.0
Description
The issue is related to a malicious server ACL event that can impact performance temporarily or permanently, leading to a persistent denial of service. Homeservers running on a closed federation are not affected. The vulnerability is associated with unregulated resource distribution.
Recommendations
For Synapse versions prior to 1.94.0, upgrade to Synapse 1.94.0 or later.
As a temporary workaround, rooms with malicious server ACL events can be purged and blocked using the
admin API.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾