PT-2023-7527

CVE-2023-49285

·

Published

2023-11-24

·

Updated

2026-09-29

Description by

CVSS 3.1
8.6
High
MetricsAV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Squid versions prior to 6.5
Description The issue is related to a Buffer Overread bug in Squid, which can be exploited by a remote attacker to cause a Denial of Service (DoS) attack against Squid HTTP Message processing. This can be achieved by sending a specially crafted HTTP request. Squid is a caching proxy for the Web that supports HTTP, HTTPS, FTP, and more.
Recommendations For Squid versions prior to 6.5, users are advised to upgrade to version 6.5 or later to fix the bug. There are no known workarounds for this issue. As a temporary workaround, consider restricting access to the Squid HTTP Message processing to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-8W9R-P88V-MMX9
ALSA-2024:0046
ALSA-2024:0071
ALT-PU-2024-9370
AZL-32072
CESA-2024_0046
DLA-3709-1
DSA-5637-1
MGASA-2024-0102
OESA-2023-1932
OPENSUSE-SU-2023_4698-1
OPENSUSE-SU-2024:13631-1
RHSA-2024:0046
RHSA-2024_0046
RHSA-2024:0071
RHSA-2024_0071
RHSA-2024:0072
RHSA-2024:0397
RHSA-2024:0771
RHSA-2024:0772
RHSA-2024:0773
RHSA-2024:1153
RHSA-2024:1787
RHSA-2024_1787
RLSA-2024:0046
ROSA-SA-2024-2479
SUSE-SU-2023:4698-1
SUSE-SU-2023_4698-1
SUSE-SU-2023:4724-1
SUSE-SU-2023_4724-1
SUSE-SU-2023:4825-1
SUSE-SU-2023_4825-1
USN-6594-1
USN-6857-1
Found an issue in the description? Have something to add? Feel free to write us 👾