PT-2023-8461

CVE-2022-31394

·

Published

2023-02-21

·

Updated

2025-03-17

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions Hyper versions prior to 0.14.19
Description The issue is related to the HTTP library for Rust Hyper, which is associated with unbounded resource allocation. This can be exploited by a remote attacker to cause a denial of service. The vulnerability is also related to the lack of customization for the max header list size method in the H2 third-party software, allowing attackers to perform HTTP2 attacks.
Recommendations For versions prior to 0.14.19, update to version 0.14.19 or later to resolve the issue. As a temporary workaround, consider restricting access to the H2 third-party software to minimize the risk of exploitation. Avoid using the max header list size method in affected API endpoints until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
AZL-13685
AZL-35218
AZL-61516
OPENSUSE-SU-2023_2637-1
OPENSUSE-SU-2023_3526-1
OPENSUSE-SU-2024_0090-1
OPENSUSE-SU-2024:12727-1
OPENSUSE-SU-2024:12728-1
OPENSUSE-SU-2024:12757-1
OPENSUSE-SU-2024:12764-1
OPENSUSE-SU-2024:12807-1
SUSE-SU-2023:1844-1
SUSE-SU-2023:2603-1
SUSE-SU-2023_2603-1
SUSE-SU-2023:2637-1
SUSE-SU-2023_2637-1
SUSE-SU-2023:3526-1
SUSE-SU-2024:0090-1
SUSE-SU-2024_0090-1
Found an issue in the description? Have something to add? Feel free to write us 👾