PT-2023-8852
CVE-2023-5535
·
Published
2023-10-11
·
Updated
2026-09-17
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
vim versions prior to 9.0.2010
Description
The issue is related to a Use After Free vulnerability in the
buf contents changed() function of the vim text editor, which is associated with the use of memory after it has been freed. Exploitation of this issue may allow an attacker to cause a denial of service.Recommendations
For versions prior to 9.0.2010, update to version 9.0.2010 or later to resolve the issue. As a temporary workaround, consider disabling the
buf contents changed() function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾