PT-2023-8967
CVE-2023-36054
·
Published
2023-07-11
·
Updated
2024-06-15
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:L/Au:S/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
MIT Kerberos 5 (aka krb5) versions 1.20.2 and earlier, 1.21.x versions prior to 1.21.1
Description
The issue is related to the lib/kadm5/kadm rpc xdr.c file in the Kerberos implementation, where an uninitialized pointer is freed. This can be exploited by a remote authenticated user to trigger a kadmind crash due to the lack of validation between
n key data and the key data array count in the xdr kadm5 principal ent rec function.Recommendations
For MIT Kerberos 5 (aka krb5) versions 1.20.2 and earlier, update to version 1.20.2 or later.
For MIT Kerberos 5 (aka krb5) 1.21.x versions prior to 1.21.1, update to version 1.21.1 or later.
As a temporary workaround, consider restricting access to the vulnerable
lib/kadm5/kadm rpc xdr.c module to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾