PT-2023-9034

CVE-2023-46234

·

Published

2023-10-26

·

Updated

2026-09-11

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:C/A:N
Name of the Vulnerable Software and Affected Versions browserify-sign versions prior to 4.2.2
Description The issue is related to an upper bound check problem in the dsaVerify function, which allows an attacker to construct signatures that can be successfully verified by any public key. This leads to a signature forgery attack. All places in the project that involve DSA verification of user-input signatures are affected by this issue.
Recommendations To resolve the issue, update to version 4.2.2 or later. As a temporary workaround, consider disabling the dsaVerify function until a patch is available. Restrict access to areas of the project that involve DSA verification of user-input signatures to minimize the risk of exploitation. Avoid using the dsaVerify function in the affected API endpoints until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-X9W5-V3Q2-3RHW
AZL-31719
DLA-3635-1
DSA-5539-1
MGASA-2025-0194
OPENSUSE-SU-2025:14663-1
USN-6800-1
Found an issue in the description? Have something to add? Feel free to write us 👾