PT-2023-9569

CVE-2024-21219

·

Published

2023-12-07

·

Updated

2025-03-17

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:L/Au:S/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions MySQL Server versions 8.0.39 and prior MySQL Server versions 8.4.2 and prior MySQL Server versions 9.0.1 and prior
Description The vulnerability in the MySQL Server product of Oracle MySQL is related to the DML component and is caused by incorrect clearance or release of resources. This issue can be exploited by a remote attacker to cause a denial of service using the MySQL protocol. Successful attacks can result in the unauthorized ability to cause a hang or frequently repeatable crash of the MySQL Server.
Recommendations For MySQL Server versions 8.0.39 and prior, update to a version later than 8.0.39 to resolve the issue. For MySQL Server versions 8.4.2 and prior, update to a version later than 8.4.2 to resolve the issue. For MySQL Server versions 9.0.1 and prior, update to a version later than 9.0.1 to resolve the issue. As a temporary workaround, consider restricting access to the MySQL Server to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALSA-2025:1671
ALSA-2025:1673
ALT-PU-2024-14481
ALT-PU-2024-14548
ALT-PU-2024-14706
ALT-PU-2024-14708
AZL-50366
AZL-50427
CESA-2025_1673
INFSA-2025_1671
INFSA-2025_1673
OESA-2024-2287
RHSA-2025:1671
RHSA-2025_1671
RHSA-2025:1673
RHSA-2025_1673
RLSA-2025:1671
RLSA-2025:1673
USN-7102-1
Found an issue in the description? Have something to add? Feel free to write us 👾