PT-2023-9628
CVE-2024-21173
·
Published
2023-12-07
·
Updated
2025-03-24
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
MySQL Server versions 8.0.37 and prior
MySQL Server versions 8.4.0 and prior
Description
The issue is related to insufficient input validation in the InnoDB component of Oracle MySQL Server. It allows a high-privileged attacker with network access via multiple protocols to compromise the MySQL Server. Successful attacks can result in the unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of the MySQL Server.
Recommendations
For MySQL Server versions 8.0.37 and prior, update to a version later than 8.0.37 to resolve the issue.
For MySQL Server versions 8.4.0 and prior, update to a version later than 8.4.0 to resolve the issue.
As a temporary workaround, consider restricting network access to the MySQL Server to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾