PT-2024-10058

CVE-2024-12356

·

Published

2024-12-16

·

Updated

2026-10-18

Description by

CVSS 2.0
10
Critical
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions BeyondTrust Privileged Remote Access (PRA) and Remote Support (RS) versions up to 24.3.1
Description A critical command injection vulnerability has been discovered in BeyondTrust's Privileged Remote Access (PRA) and Remote Support (RS) products. This vulnerability can allow an unauthenticated attacker to inject commands that are run as a site user, potentially leading to remote code execution. The vulnerability is being actively exploited in the wild, with reports of Chinese hackers targeting exposed systems. It is estimated that over 8,600 BeyondTrust systems remain exposed online, with 72% of them located in the US. The vulnerability has been used in real-world incidents, including a breach of the US Treasury Department.
Recommendations For BeyondTrust Privileged Remote Access (PRA) and Remote Support (RS) versions up to 24.3.1, apply the patch to prevent remote code execution risks. For on-premise systems, upgrade to at least 22.1.x before applying the patch to protect against the vulnerability. As a temporary workaround, consider restricting access to the vulnerable module to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
RHSA-2025:1720
RHSA-2025:1721
RHSA-2025:1722
RHSA-2025:1723
RHSA-2025:1724
RHSA-2025:1725
RHSA-2025:1726
RHSA-2025:1727
RHSA-2025:1728
RHSA-2025:1729
RHSA-2025:1730
RHSA-2025:1731
RHSA-2025:1732
RHSA-2025:1733
RHSA-2025:1735
RHSA-2025:1736
RHSA-2025:1737
RHSA-2025:1738
RHSA-2025:1739
RHSA-2025:1740
RHSA-2025:1741
RHSA-2025:1742
RHSA-2025:1743
RHSA-2025:1744
RHSA-2025:1745
RHSA-2025:3050
RHSA-2025:3062
RHSA-2025:3063
RHSA-2025:3064
RHSA-2025:3082
RHSA-2025:3978
Found an issue in the description? Have something to add? Feel free to write us 👾