PT-2024-10751

CVE-2019-25220

·

Published

2024-11-18

·

Updated

2024-11-18

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Bitcoin Core versions prior to 24.0.1
Description The issue allows remote attackers to cause a denial of service, resulting in a daemon crash, via a flood of low-difficulty header chains, also known as a "Chain Width Expansion" attack. This occurs because a node does not first verify that a presented chain has enough work before committing to store it.
Recommendations For versions prior to 24.0.1, update to version 24.0.1 or later to resolve the issue. As a temporary workaround, consider implementing measures to limit the impact of a flood of low-difficulty header chains, such as restricting incoming connections or adjusting node configuration to require verification of work before storing chains.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾