PT-2024-12548

CVE-2023-36177

·

Published

2024-01-23

·

Updated

2026-09-15

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions snapcast versions prior to 0.23.0+dfsg1-1+deb11u1 snapcast versions prior to 0.26.0+dfsg1-1+deb12u1 snapcast version 0.27.0
Description An RCE vulnerability exists in snapcast, a multi-room client-server audio player. Remote attackers can execute arbitrary code and gain sensitive information via crafted requests to the JSON-RPC-API. The vulnerability resides in the JSON RPC interface of the server component.
Recommendations snapcast versions prior to 0.23.0+dfsg1-1+deb11u1: Upgrade your snapcast packages to version 0.23.0+dfsg1-1+deb11u1 or later. snapcast versions prior to 0.26.0+dfsg1-1+deb12u1: Upgrade your snapcast packages to version 0.26.0+dfsg1-1+deb12u1 or later. snapcast version 0.27.0: At the moment, there is no information about a newer version that contains a fix for this vulnerability.
Exploitability
Exploit
Impacts
Vendors
Affected products
Related identifiers
DLA-4252-1
DSA-5847-1
USN-8767-1
Found an issue in the description? Have something to add? Feel free to write us 👾