PT-2024-15052

CVE-2023-6694

·

Published

2024-04-09

·

Updated

2024-04-10

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Beaver Themer plugin for WordPress versions up to, and including, 1.4.9
Description The issue is related to Stored Cross-Site Scripting via the plugin's shortcode(s) due to insufficient input sanitization and output escaping on user-supplied custom fields. This allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For versions up to, and including, 1.4.9, update to a version later than 1.4.9 to resolve the issue. As a temporary workaround, consider restricting access to the plugin's shortcode(s) to minimize the risk of exploitation. Additionally, restrict permissions to prevent authenticated attackers with contributor-level and above permissions from injecting arbitrary web scripts.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾