PT-2024-15092
CVE-2023-6808
·
Published
2024-02-05
·
Updated
2024-02-09
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Booking for Appointments and Events Calendar – Amelia plugin for WordPress versions up to, and including, 1.0.93
Description
The issue is related to Stored Cross-Site Scripting via the plugin's shortcode(s) due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 1.0.93, update to a version later than 1.0.93 to resolve the issue.
As a temporary workaround, consider restricting access to the plugin's shortcode(s) to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾