PT-2024-15416

CVE-2024-0256

·

Published

2024-02-06

·

Updated

2024-02-14

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Starbox plugin for WordPress versions up to, and including, 3.4.8
Description The issue is related to Stored Cross-Site Scripting via the Profile Display Name and Social Settings due to insufficient input sanitization and output escaping. This allows authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For versions up to, and including, 3.4.8, update to a version later than 3.4.8 to resolve the issue. As a temporary workaround, consider restricting access to the Profile Display Name and Social Settings features to minimize the risk of exploitation. Additionally, restrict subscriber-level access and above to reduce the potential attack surface.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾