PT-2024-1595
CVE-2024-23835
·
Published
2024-02-08
·
Updated
2025-07-28
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Suricata versions prior to 7.0.3
Description
The issue is related to excessive memory use during pgsql parsing, which could lead to OOM-related crashes. This can be exploited by a remote attacker to cause a denial of service.
Recommendations
For versions prior to 7.0.3, update to version 7.0.3 to resolve the issue.
As a temporary workaround, consider disabling the pgsql app layer parser until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾