PT-2024-15999

CVE-2024-10055

·

Published

2024-10-18

·

Updated

2024-10-22

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Click to Chat – WP Support All-in-One Floating Widget plugin for WordPress versions up to, and including, 2.3.3
Description The issue is related to Stored Cross-Site Scripting via the plugin's wpsaio snapchat shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For Click to Chat – WP Support All-in-One Floating Widget plugin for WordPress versions up to, and including, 2.3.3, update to a version later than 2.3.3 to resolve the issue. As a temporary workaround, consider disabling the wpsaio snapchat shortcode until a patch is available. Restrict access to the wpsaio snapchat shortcode to minimize the risk of exploitation. Avoid using user-supplied attributes in the affected shortcode until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾