PT-2024-16189

CVE-2024-10325

·

Published

2024-11-08

·

Updated

2024-11-13

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Elementor Header & Footer Builder plugin for WordPress versions up to, and including, 1.6.45
Description The issue is related to Stored Cross-Site Scripting via REST API SVG File uploads due to insufficient input sanitization and output escaping. This allows authenticated attackers with Author-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Recommendations For versions up to, and including, 1.6.45, update to a version later than 1.6.45 to resolve the issue. As a temporary workaround, consider restricting access to the REST API SVG File uploads until a patch is available. Additionally, limiting user access to Author-level and above can help minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾