PT-2024-16389

CVE-2024-10592

·

Published

2024-11-16

·

Updated

2024-11-18

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Mapster WP Maps plugin for WordPress version 1.6.0 and earlier
Description The issue is related to Stored Cross-Site Scripting via the popup class parameter due to insufficient input sanitization and output escaping. This allows authenticated attackers with Contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For version 1.6.0 and earlier, update to a version later than 1.6.0 to resolve the issue. As a temporary workaround, consider restricting access to the popup class parameter to minimize the risk of exploitation. Additionally, ensure that all users with Contributor-level access and above are trusted, as they have the ability to inject arbitrary web scripts.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾