PT-2024-16457

CVE-2024-10682

·

Published

2024-11-20

·

Updated

2024-11-21

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions The Announcement & Notification Banner – Bulletin plugin for WordPress versions up to, and including, 3.11.7
Description The issue is related to Reflected Cross-Site Scripting, which occurs due to the use of add query arg and remove query arg without proper escaping on the URL. This allows unauthenticated attackers to inject arbitrary web scripts into pages, which execute when a user performs a specific action, such as clicking on a link.
Recommendations For versions up to, and including, 3.11.7, update to a version higher than 3.11.7 to resolve the issue. As a temporary workaround, consider restricting access to the plugin's functionality until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾