PT-2024-17257
CVE-2024-11785
·
Published
2024-12-12
·
Updated
2024-12-12
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Integrate Firebase plugin for WordPress versions up to and including 0.9.3
Description
The issue is related to Stored Cross-Site Scripting via the plugin's 'firebase show' shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to and including 0.9.3, update to a version higher than 0.9.3 to resolve the issue.
As a temporary workaround, consider restricting access to the 'firebase show' shortcode until a patch is available.
Restrict contributor-level access and above to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾