PT-2024-17405

CVE-2024-12024

·

Published

2024-12-17

·

Updated

2025-01-10

Description by

CVSS 3.1
7.2
High
MetricsAV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions EventPrime – Events Calendar, Bookings and Tickets plugin for WordPress versions up to, and including, 4.0.5.3
Description The issue is related to Stored Cross-Site Scripting via the em ticket category data and em ticket individual data parameters due to insufficient input sanitization and output escaping. This allows unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrative user accesses an injected page. The vulnerability requires the "Guest Submissions" setting to be enabled, which is disabled by default.
Recommendations For versions up to, and including, 4.0.5.3, update to a version later than 4.0.5.3 to resolve the issue. As a temporary workaround, consider disabling the "Guest Submissions" setting to minimize the risk of exploitation. Restrict access to the em ticket category data and em ticket individual data parameters to prevent arbitrary web script injection.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾