PT-2024-17423

CVE-2024-12061

·

Published

2024-12-18

·

Updated

2024-12-18

Description by

CVSS 3.1
4.3
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions Events Addon for Elementor plugin for WordPress versions up to, and including, 2.2.3
Description The issue concerns insufficient restrictions on which posts can be included via the naevents elementor template shortcode. This allows authenticated attackers with Contributor-level access and above to extract data from private or draft posts created by Elementor that they should not have access to.
Recommendations For versions up to, and including, 2.2.3, update to a version higher than 2.2.3 to resolve the issue. As a temporary workaround, consider restricting access to the naevents elementor template shortcode to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾