PT-2024-17660

CVE-2024-12572

·

Published

2024-12-13

·

Updated

2024-12-13

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Hello In All Languages plugin for WordPress versions up to, and including, 1.0.6
Description The issue is due to missing or incorrect nonce validation on a function, allowing unauthenticated attackers to update settings and inject malicious web scripts via a forged request. This can happen if attackers can trick a site administrator into performing an action such as clicking on a link.
Recommendations For versions up to, and including, 1.0.6, update to a version higher than 1.0.6 to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable function until a patch is available. Avoid using the plugin until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾