PT-2024-17692

CVE-2024-12652

·

Published

2024-12-26

·

Updated

2026-03-02

Description by

CVSS 4.0
9.3
Critical
MetricsAV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:H
Name of the Vulnerable Software and Affected Versions SmartRobot's Conversational AI Platform versions prior to 7.2.0
Description A Code Injection vulnerability exists in the groovy script function of SmartRobot's Conversational AI Platform, allowing remote authenticated users to perform arbitrary system commands via Groovy code. This enables remote users to execute system commands.
Recommendations For versions prior to 7.2.0, update to version 7.2.0 to patch this issue. As a temporary workaround, consider restricting access to the groovy script function until the update is applied.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾