PT-2024-17712
CVE-2024-12678
·
Published
2024-12-19
·
Updated
2025-12-12
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:L/Au:S/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Hashicorp Nomad versions prior to 1.9.4
Hashicorp Nomad versions prior to 1.8.8
Hashicorp Nomad versions prior to 1.7.16
Description
The issue is related to privilege escalation within a namespace through unredacted workload identity tokens. This allows for potential exploitation, although specific details about the number of affected devices or real-world incidents are not provided.
Recommendations
For versions prior to 1.9.4, update to Nomad Community Edition 1.9.4.
For versions prior to 1.8.8, update to Nomad Enterprise 1.8.8.
For versions prior to 1.7.16, update to Nomad Enterprise 1.7.16.
Found an issue in the description? Have something to add? Feel free to write us 👾