PT-2024-17729

CVE-2024-1277

·

Published

2024-02-20

·

Updated

2025-03-04

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Ocean Extra plugin for WordPress versions up to, and including, 2.2.4
Description The issue is related to Stored Cross-Site Scripting via custom fields due to insufficient input sanitization and output escaping. This allows authenticated attackers with contributor access or higher to inject arbitrary web scripts in pages, which will execute when a user accesses an injected page.
Recommendations For Ocean Extra plugin for WordPress versions up to, and including, 2.2.4, update to a version higher than 2.2.4 to resolve the issue. As a temporary workaround, consider restricting contributor access to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾