PT-2024-18153

CVE-2024-1589

·

Published

2024-04-07

·

Updated

2025-03-24

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions SendPress Newsletters WordPress plugin versions 1.23.11.6 and earlier
Description The issue allows high privilege users, such as admins, to perform Stored Cross-Site Scripting attacks, even when the unfiltered html capability is disallowed, for example, in multisite setups. This is due to the plugin not sanitizing and escaping some of its settings.
Recommendations For SendPress Newsletters WordPress plugin versions 1.23.11.6 and earlier, update to a version later than 1.23.11.6 to resolve the issue. As a temporary workaround, consider restricting access to the plugin's settings for high privilege users until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾