PT-2024-18474

CVE-2024-1986

·

Published

2024-03-07

·

Updated

2025-03-11

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Booster Elite for WooCommerce plugin for WordPress versions up to, and including, 7.1.7
Description The issue arises from missing file type validation in the wc add new product() function, allowing arbitrary file uploads. This could potentially lead to remote code execution when the user product upload functionality is enabled, exploitable by customer-level attackers and above.
Recommendations For versions up to, and including, 7.1.7, update to a version newer than 7.1.7 to resolve the issue. As a temporary workaround, consider disabling the user product upload functionality until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾