PT-2024-18546
CVE-2024-2006
·
Published
2024-03-13
·
Updated
2025-03-13
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
The Post Grid, Slider & Carousel Ultimate plugin for WordPress versions up to, and including, 1.6.7
Description
The issue allows authenticated attackers with contributor-level access and above to inject a PHP Object via deserialization of untrusted input in the
outpost shortcode metabox markup function. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.Recommendations
For versions up to, and including, 1.6.7, update to a version higher than 1.6.7 to resolve the issue. As a temporary workaround, consider restricting access to the
outpost shortcode metabox markup function until a patch is available. Additionally, review installed plugins and themes for potential POP chains and update or remove them as necessary to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾