PT-2024-18820
CVE-2024-20972
·
Published
2024-01-16
·
Updated
2025-03-29
Description by
CVSS 3.1
4.9
MediumMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
MySQL Server versions 8.0.35 and prior
MySQL Server versions 8.2.0 and prior
Description
The issue allows a high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks can result in unauthorized ability to cause a hang or frequently repeatable crash of MySQL Server.
Recommendations
For MySQL Server versions 8.0.35 and prior, update to a version later than 8.0.35.
For MySQL Server versions 8.2.0 and prior, update to a version later than 8.2.0.
As a temporary workaround, consider restricting network access to the MySQL Server to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾