PT-2024-19118
CVE-2024-21905
·
Published
2024-04-26
·
Updated
2025-12-05
Description by
CVSS 3.1
8.2
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
Name of the Vulnerable Software and Affected Versions
QNAP QTS versions prior to 5.1.3.2578 build 20231110
QNAP QuTS hero versions prior to 5.1.3.2578 build 20231110
QNAP QuTScloud versions prior to 5.1.5.2651
Description
An integer overflow or wraparound issue has been reported to affect several QNAP operating system versions. If exploited, this could allow users to compromise the security of the system via a network.
Recommendations
For QNAP QTS versions prior to 5.1.3.2578 build 20231110, update to QTS 5.1.3.2578 build 20231110 or later.
For QNAP QuTS hero versions prior to 5.1.3.2578 build 20231110, update to QuTS hero 5.1.3.2578 build 20231110 or later.
For QNAP QuTScloud versions prior to 5.1.5.2651, update to QuTScloud 5.1.5.2651 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾