PT-2024-19828
CVE-2024-23349
·
Published
2024-02-22
·
Updated
2025-03-28
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Apache Answer versions through 1.2.1
Description
The issue is related to improper neutralization of input during web page generation, also known as cross-site scripting. This occurs when a logged-in user modifies their own submitted question and inputs malicious code in the summary, creating an XSS attack.
Recommendations
For Apache Answer versions through 1.2.1, upgrade to version 1.2.5, which fixes the issue. As a temporary workaround, consider restricting the input of malicious code in the summary field to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾