PT-2024-2015
CVE-2024-26625
·
Published
2024-01-30
·
Updated
2026-10-21
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.8.0
Description
The vulnerability exists due to insufficient input validation in the sock orphan() function of the Linux kernel. Exploitation of the vulnerability may allow an attacker to impact the confidentiality, integrity, and availability of protected information. The issue is caused by a stale sk->sk wq pointer in a closed llc socket.
Recommendations
To resolve the issue, update the Linux kernel to version 6.8.0 or later. If updating is not possible, consider temporarily disabling the sock orphan() function until a patch is available. However, this is not recommended as it may cause other issues.
Note: The provided information does not specify the exact versions affected, but it mentions that the issue is resolved in version 6.8.0. Therefore, it is assumed that all versions prior to 6.8.0 are affected.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾