PT-2024-20321
CVE-2024-2423
·
Published
2024-04-09
·
Updated
2025-09-29
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WordPress versions up to, and including, 1.2.6
Description
The issue arises from insufficient input sanitization and output escaping on user-supplied attributes in the plugin's shortcode(s), allowing authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages. This enables the execution of injected scripts whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 1.2.6, update to a version later than 1.2.6 to resolve the issue. As a temporary workaround, consider restricting access to the plugin's shortcode(s) to prevent authenticated attackers from injecting arbitrary web scripts.
Found an issue in the description? Have something to add? Feel free to write us 👾