PT-2024-20607
CVE-2024-2484
·
Published
2024-06-21
·
Updated
2024-06-24
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Orbit Fox by ThemeIsle plugin for WordPress versions up to, and including, 2.10.34
Description
The issue is related to Stored Cross-Site Scripting via the Services and Post Type Grid widgets due to insufficient input sanitization and output escaping. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 2.10.34, update to a version higher than 2.10.34 to resolve the issue. As a temporary workaround, consider restricting access to the Services and Post Type Grid widgets to minimize the risk of exploitation. Additionally, restrict contributor-level access and above to prevent authenticated attackers from injecting arbitrary web scripts.
Found an issue in the description? Have something to add? Feel free to write us 👾