PT-2024-20754

CVE-2024-25112

·

Published

2024-02-12

·

Updated

2026-10-01

Description by

CVSS 3.1
5.5
Medium
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Exiv2 versions v0.28.0 through v0.28.1
Description Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A denial-of-service was found in Exiv2, caused by an unbounded recursion that can cause Exiv2 to crash by exhausting the stack. The vulnerable function, QuickTimeVideo::multipleEntriesDecoder, was new in v0.28.0. The denial-of-service is triggered when Exiv2 is used to read the metadata of a crafted video file.
Recommendations For Exiv2 versions v0.28.0 through v0.28.1, upgrade to version v0.28.2 to resolve the issue. As a temporary workaround, consider avoiding the use of the QuickTimeVideo::multipleEntriesDecoder function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-CRMJ-QH74-2R36
ALT-PU-2024-2322
AZL-42515
AZL-42558
CLEANSTART-2024-GA74818
OPENSUSE-SU-2024:13731-1
OPENSUSE-SU-2026:20410-1
PYSEC-2024-107
SUSE-SU-2026:20923-1
Found an issue in the description? Have something to add? Feel free to write us 👾