PT-2024-21662

CVE-2024-27124

·

Published

2024-04-26

·

Updated

2025-12-05

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions QNAP QTS versions prior to 5.1.3.2578 build 20231110 QNAP QTS versions prior to 4.5.4.2627 build 20231225 QNAP QuTS hero h versions prior to h5.1.3.2578 build 20231110 QNAP QuTS hero h versions prior to h4.5.4.2626 build 20231225 QNAP QuTScloud c versions prior to c5.1.5.2651
Description An OS command injection vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow users to execute commands via a network.
Recommendations Update to QTS 5.1.3.2578 build 20231110 or later. Update to QTS 4.5.4.2627 build 20231225 or later. Update to QuTS hero h5.1.3.2578 build 20231110 or later. Update to QuTS hero h4.5.4.2626 build 20231225 or later. Update to QuTScloud c5.1.5.2651 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
ZDI-24-473
ZDI-24-824
Found an issue in the description? Have something to add? Feel free to write us 👾